Forum Settings
Forums
Pages (19) [1] 2 3 » ... Last »
Must be a Club Member to Reply 
#1
Mar 7, 2012 4:10 PM

Offline
Joined: Jul 2009
Posts: 393
MALgraph doesn't render properly on your browser? Your stats are wrong? If you find any bugs, please report them here.
Modified by fri, Feb 23, 2013 11:47 AM
 
#2
Mar 15, 2012 6:27 AM

Offline
Joined: Jun 2010
Posts: 144
One of my friends' profiles doesn't come up.

Link to his profile : http://myanimelist.net/profile/CoolingGibbon

MALgraph : http://mal.oko.im/CoolingGibbon

But it might be that the problem is with MAL with some server glitch. But still, pointed it out, just in case.
 
#3
Mar 15, 2012 7:08 AM

Offline
Joined: Jul 2009
Posts: 393
It works now. I was updating a few files at that time and your request might've fallen into despair.
 
#4
Mar 15, 2012 9:12 AM

Offline
Joined: Jul 2010
Posts: 397
The "total time" on MALgraph and the "Time (Days)" on MAL don't match. I don't know if it's due to lag, an error or they are calculated in different ways (rewatch?).
 
#5
Mar 15, 2012 9:41 AM

Offline
Joined: Jul 2009
Posts: 393
Rewatches are not implemented... yet? Anyway, we get the time from entry's page, multiply it by episode count and voila. It should be precise, so we're not sure why it's that much off from MAL's counters. The difference for users varies from positive to negative, and that's even weirder.
 
#6
Mar 15, 2012 1:38 PM
Offline
Joined: Mar 2010
Posts: 1
http://mal.oko.im/sm

Doesn't even work for me. Fix it. A lot of the features don't even need ratings.
 
#7
Mar 15, 2012 3:59 PM

Offline
Joined: Jul 2009
Posts: 393
Point. Nice suggestion; chrupky edited it and now it displays basic data that doesn't need ratings.
Check it out now.
 
#8
Mar 15, 2012 5:10 PM

Offline
Joined: Mar 2009
Posts: 24
The site does not do anything on my iPhone when I send my username or click the anime/manga tabs.
 
#9
Mar 16, 2012 12:05 PM

Offline
Joined: Jul 2010
Posts: 397
fri said:
we're not sure why it's that much off from MAL's counters. The difference for users varies from positive to negative, and that's even weirder.
I think the score to time distribution for (at least) manga doesn't count series you are reading. I have ~800 chapters rated 10, but it doesn't show any time.
 
Mar 16, 2012 2:37 PM

Offline
Joined: Nov 2008
Posts: 225
Not an error but there's a typo.

Acitivity timeline
 
Mar 16, 2012 2:47 PM

Offline
Joined: Jul 2009
Posts: 393
Yandy said:
Not an error but there's a typo.
Acitivity timeline

Fixed. Also, the suggestions list for manga should now expand properly (refresh the page if your browser didn't reload the javascript).
 
Mar 16, 2012 8:56 PM
Offline
Joined: Apr 2009
Posts: 1
For my personal MALgraph page (I haven't checked this for other people's pages), the number it states for series I've completed is 303, but the actual number on MAL is 301. Not sure what could cause this miscalculation.
 
Mar 16, 2012 11:18 PM

Offline
Joined: Jun 2010
Posts: 144
@PerfectChaos : It shows 303 on MALgraph to me, as well
 
Mar 16, 2012 11:58 PM

Offline
Joined: Nov 2010
Posts: 87
PerfectChaos said:
For my personal MALgraph page (I haven't checked this for other people's pages), the number it states for series I've completed is 303, but the actual number on MAL is 301. Not sure what could cause this miscalculation.


We get our info from this: http://myanimelist.net/malappinfo.php?u=PerfectChaos&status=all
Everything that has my_status equal to 2 is supposed to be completed by given user. According to this, you completed 303 titles.

I investigated this a bit and I discovered something quite surprising as well as somewhat obvious. I did manual diff of list reported by API and your official list and it seemed like following two titles were somehow missing from completed list in http://myanimelist.net/animelist/PerfectChaos :

  • Baka to Test to Shoukanjuu
  • Death Note

    And that's right, they actually were missing. Coincidentally, you rewatch both of them; that's why they aren't shown on completed list. Since you did complete them, in a way the "303" you see is not wrong.
  •  
    Mar 17, 2012 12:49 AM

    Offline
    Joined: Nov 2010
    Posts: 87
    LazYSlackeR said:
    fri said:
    we're not sure why it's that much off from MAL's counters. The difference for users varies from positive to negative, and that's even weirder.
    I think the score to time distribution for (at least) manga doesn't count series you are reading. I have ~800 chapters rated 10, but it doesn't show any time.


    Thanks for pointing that out. I just fixed it and apart from fixing the issue you mentioned, it will also reduce difference between time spent calculated by MAL and by us. However, we won't upload this just yet due to other features being worked on (namely customizable export graphs.)
     
    Mar 17, 2012 4:25 AM

    Offline
    Joined: Jun 2010
    Posts: 144
    I was wondering, for the part where in anime section, days are appearing more than the MAL one, are they counting the time for Plan to Watch as well?

    Or maybe instead of the episodes we watched, it is counting the total episode time of the series in our list?

    Just guessing things here and there.
     
    Mar 17, 2012 10:14 AM

    Offline
    Joined: Jan 2010
    Posts: 1163
    On the "List of anime you could've overlooked," it says the titles on the left are sorted by my score, which doesn't seem to be entirely true. Of the first seven titles listed, three of them aren't even a 9 or 10 (Shakugan no Shana, Legend of the Galactic Heroes: My Conquest Is the Sea of Stars, Steins;Gate), and Shakugan no Shana in particular stands out as being quite the deviation in score from the other six shows, despite being the second anime listed.
    "My tables-meet it is I set it down
    That one may smile, and smile, and be a villain."
     
    Mar 18, 2012 4:17 AM

    Offline
    Joined: Nov 2010
    Posts: 87
    NavyCherub said:
    On the "List of anime you could've overlooked," it says the titles on the left are sorted by my score, which doesn't seem to be entirely true. Of the first seven titles listed, three of them aren't even a 9 or 10 (Shakugan no Shana, Legend of the Galactic Heroes: My Conquest Is the Sea of Stars, Steins;Gate), and Shakugan no Shana in particular stands out as being quite the deviation in score from the other six shows, despite being the second anime listed.


    Thank you for pointing that out. Fixed (code was kind of fubar TBH).
    Changes will become visible in 48 hours.
     
    Mar 18, 2012 9:10 AM

    Offline
    Joined: Jun 2010
    Posts: 144
    I am not sure, if it is a bug as per say, but

    In my manga list, it appears like this :



    Why is the highest mean 10.10? In fact, nothing can go beyond 10.
     
    Mar 18, 2012 12:06 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    We're adding 0.1 to the highest value and subtracting 0.1 from the lowest one to add margins to the graph. Otherwise you would see only half of those blue dots for 1980 and 2010.

    While it might look weird, I don't think it's a bug worth fixing.
     
    Mar 19, 2012 8:06 AM

    Offline
    Joined: Jul 2009
    Posts: 273
    dunno if it's bug but matrix theme has black background and so the numbers for each score is invisible as of it , well i think the theme looks very good but it seems the text color should have been changed :p
     
    Mar 19, 2012 2:05 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    I fixed it and refreshed your image, though it looks like you've changed it to 'flame' before I applied the fix. Anyway, it works now.
     
    Mar 20, 2012 12:16 AM

    Offline
    Joined: May 2008
    Posts: 130
    Equivalent proportions should be equivalent (5 and 6):


    It's probably a rounding error.
    Dermatitus have plagued men for millenia. Peace, THERE IS NO CURE.
     
    Mar 20, 2012 7:55 AM

    Offline
    Joined: Jul 2009
    Posts: 393
    We had two choices:
    a) use basic round( )
    - pros: there wouldn't be a situation similar to the one you posted; easy calculations
    - cons: percents would rarely add up to 100
    b) use a special formula
    - pros: percents add up to 100 every single time
    - cons: there might be weird results where equal numbers result in different percentages

    As you can see, we went with the latter approach.

    To be honest, I'm surprised you noticed that. I'm glad some of you take your time to look closely and even report and share your doubts. Thank you!
     
    Mar 20, 2012 2:23 PM

    Offline
    Joined: May 2008
    Posts: 130
    How about using decimal places if your aim is to be precise? One should be sufficient.

    Either way though, it's not a big deal even if you don't change it.
    Dermatitus have plagued men for millenia. Peace, THERE IS NO CURE.
     
    Mar 20, 2012 3:01 PM

    Offline
    Joined: Jul 2010
    Posts: 397
    deadskin said:
    How about using decimal places if your aim is to be precise? One should be sufficient.
    I think that way it would still be off by 0.1

    You could add a note explaining it somewhere, maybe in the "?" button where you explain the formula?
     
    Mar 26, 2012 2:35 PM

    Offline
    Joined: Aug 2008
    Posts: 3597
    Seems like it's not working for older versions of FF (e. g. 3.6). Just telling. And please don't tell me to update it...
    Ii tenki desu ne...
     
    Mar 26, 2012 3:19 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    Antanaru said:
    Seems like it's not working for older versions of FF (e. g. 3.6). Just telling. And please don't tell me to update it...

    Don't update your Firefox. Switch to Opera.
     
    Mar 27, 2012 12:05 PM

    Offline
    Joined: Nov 2008
    Posts: 225
    Something's wrong. http://mal.oko.im/Yandy

    User not found.

    "Yandy"? Never heard that name.

    Check the spelling, click the home tab any try again. You can do it!
     
    Mar 27, 2012 12:16 PM
    Offline
    Joined: Nov 2008
    Posts: 4
    http://mal.oko.im/knuckztve

    Same for me either. Never heard that name, even though iI spelled it correctly
     
    Mar 27, 2012 9:22 PM

    Offline
    Joined: Aug 2011
    Posts: 1646
    MALgraph apparently thinks I don't exist anymore.

    http://mal.oko.im/DraconisMarch

    Seems to work for other friends I've tried. It was working just a little earlier today, too...

    EDIT: Nevermind. I exist again.
    Modified by DraconisMarch, Mar 28, 2012 2:06 AM
     
    Mar 27, 2012 10:22 PM

    Offline
    Joined: Jul 2011
    Posts: 3089
    Same problem here too.
    I don't exist :O scary :/

    "A half moon, it has a dark half and a bright half, just like me…"
     
    Mar 28, 2012 4:07 AM

    Offline
    Joined: Jul 2009
    Posts: 393
    That's because MAL was down yesterday. I can't do much in such situations, except for refreshing your data (which I just did, your profiles work now).

    shadowtsunami said:
    For some reason when I go and change the font color below the graph it goes, haywire and makes everything centered for some reason, and makes a link where there isn't supposed to be one. The only way I can fix it is to delete the code for malgraph, and then put it back again.

    Here's what it looks like after I deleted the code and put it back again
    http://s1186.photobucket.com/albums/z375/shadowtsunami/?action=view&current=malgraphnormal.png

    Here's what it looks like after changing the font color for one of my anime titles.
    http://s1186.photobucket.com/albums/z375/shadowtsunami/?action=view&current=malgraphproblem.png (The red box points it out)

    And when inspecting the code I noticed that the [/center] would go all the way to the bottom and anything with a link directly below it ended up looking like this <a href="http://www.anime-planet.com/users/shadowtsunami" target="_blank">
    This is the dreaded bug in MAL's BBCode. If you edit your profile (with normal BBCode), save it and try to edit it again, you'll notice that some tags were changed to their HTML counterparts. The only way you can avoid it is to use some browser add-on that saves your textarea or save your profile code in a .txt file. This bug in MAL has been present since someone hacked the forums and broke something big.
     
    Mar 28, 2012 6:24 AM

    Offline
    Joined: Apr 2008
    Posts: 800
    fri said:
    That's because MAL was down yesterday. I can't do much in such situations, except for refreshing your data (which I just did, your profiles work now).



    I can not access to my page of mygraph

    http://mal.oko.im/KiraYoshikage
     
    Mar 28, 2012 7:46 AM

    Offline
    Joined: Jul 2009
    Posts: 393
    KiraYoshikage said:
    I can not access to my page of mygraph
    http://mal.oko.im/KiraYoshikage
    It works now.

    shadowtsunami said:
    I just took a screenshot of my graph and made it a regular image that doesn't update lol. Oh well I can live with it.
    You can use your autoupdating image as usual, there's no difference between using it and any other image.
     
    Mar 28, 2012 2:55 PM

    Offline
    Joined: Apr 2011
    Posts: 141
    Is it me, or is the autoupdating image not working currently? Right now it's displaying "404 :(" instead of the usual graph on my profile, and basically everyone elses' including your profile fri.

    I assume this is due to MALGraph apparently being down recently?

    Edit: Nevermind, seems it's fixed now.
    Modified by BigOnAnime, Mar 28, 2012 2:59 PM
     
    Mar 28, 2012 3:00 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    BigOnAnime said:
    I assume this is due to MALGraph apparently being down recently?
    It was MAL which was down, not MALgraph. That fuxed some things up and some images that got caught up in that downtime don't work. I fixed yours before you posted that, by the way.
     
    Mar 28, 2012 6:33 PM

    Offline
    Joined: Feb 2008
    Posts: 1639
    I tried http://mal.oko.im/TomoyoSakagami89 and I seem to be having the error of "never heard that name". I guess you have to fix it manually? http://mal.oko.im/Mannii doesn't work either.
     
    Mar 28, 2012 9:21 PM

    Offline
    Joined: Jun 2009
    Posts: 68
    http://mal.oko.im/EedrA I also have the never heard that name error.

    EDIT: nevermind. it's okay now.
    Modified by eedra, Mar 28, 2012 10:30 PM
     
    Mar 29, 2012 12:21 PM

    Offline
    Joined: Jan 2010
    Posts: 1163
    Not really a 'bug' per se, but in the description for the achievement 'Me? PILOT this thing?!', mecha level 1, it says "We know it's your first time you see such a huge mecha, but you must pilot it." Some grammar mistakes there - it should either be "We know it's your first time seeing such a huge mecha, but you must pilot it." or "We know it's the first time you've seen such a huge mecha, but you must pilot it."
    Modified by NavyCherub, Mar 29, 2012 12:37 PM
    "My tables-meet it is I set it down
    That one may smile, and smile, and be a villain."
     
    Mar 29, 2012 12:34 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    NavyCherub said:
    Not really a 'bug' per se, but in the description for the achievement 'Me? PILOT this thing?!', mecha level 1, it says "We know it's your first time you see such a huge mecha, but you must pilot it." Some grammar mistakes there - it should either be "We know it's your first time seeing such a huge mecha, but you must pilot it." or "We know if the first time you've seen such a huge mecha, but you must pilot it."
    Thanks! I'm not a native English speaker, so I might make some spelling mistakes. If you see any other mistakes please post them here.

    Also, if you have some ideas regarding achievements, head to suggestions thread. We couldn't think of any good manga achievements, since our manga lists are pretty short.
     
    Mar 29, 2012 1:46 PM
    Offline
    Joined: Jan 2009
    Posts: 1
    Is there something up with the achievements? Some people have them and others don't.
     
    Mar 29, 2012 4:37 PM

    Offline
    Joined: Oct 2011
    Posts: 540
    Uh, I'm getting the name error bug, too.
    http://mal.oko.im/kurano

    Actually been having that error for 3 days now, but I just remembered now.

    EDIT: Thanks Fri! It works now. MALGraph is such a great invention, btw. :D
    Modified by Kurano, Mar 29, 2012 5:10 PM
    Signature removed. Please follow the signature rules, as defined in the Site & Forum Guidelines.
     
    Mar 29, 2012 4:57 PM

    Offline
    Joined: Jul 2009
    Posts: 393
    Fogun said:
    Is there something up with the achievements? Some people have them and others don't.
    That would mean they didn't deserve them!

    Kurano said:
    Uh, I'm getting the name error bug, too.
    http://mal.oko.im/kurano

    Actually been having that error for 3 days now, but I just remembered now.
    POOF! Magic.

    I can't do much when MAL itself goes down. All third-party apps are unable to work correctly, since they can't access your data - and MALgraph is no exception. The only thing I can do is manually refresh your profile or have you wait a few days for cron to remove all your cached data completely.
     
    Mar 31, 2012 5:55 AM

    Offline
    Joined: Apr 2009
    Posts: 644
    Not exactly a bug, but I think that licensing companies shoud be filtered out in "Favorite producers" graph, since there's no point in havng them there.
     
    Mar 31, 2012 7:54 AM

    Offline
    Joined: Jul 2009
    Posts: 393
    Sae said:
    Not exactly a bug, but I think that licensing companies shoud be filtered out in "Favorite producers" graph, since there's no point in havng them there.
    Yeah, I already started working on filling the exclusion list. This way we can change it back to "studios".
     
    Mar 31, 2012 9:31 AM

    Offline
    Joined: Sep 2010
    Posts: 27
    Regarding the achievements, I have a level 1 in the Mecha but it says that I've seen only 27 mecha titles and when it counts the titles I've seen it excludes titles that are tagged with Mecha by MAL. For example Zoids, FLCL, Dai-Guard and Linebarrels of Iron.
    Napalm sticks to kids

     
    Apr 2, 2012 2:15 AM
    Offline
    Joined: Feb 2008
    Posts: 558
    Nothing shows up when I hover over genres/studios on my page.

    I've tried with other peoples and it does though.
     
    Apr 2, 2012 3:09 AM

    Offline
    Joined: Jul 2009
    Posts: 393
    biggy_boy said:
    Nothing shows up when I hover over genres/studios on my page.
    I've tried with other peoples and it does though.
    Your profile was still using version 0.206. Usually, you have to wait 24 hours for the cache to expire and re-generate again. It's fresh now.
    KnightmareX13 said:
    Regarding the achievements, I have a level 1 in the Mecha but it says that I've seen only 27 mecha titles and when it counts the titles I've seen it excludes titles that are tagged with Mecha by MAL. For example Zoids, FLCL, Dai-Guard and Linebarrels of Iron.
    Added, as stated in the changelog.
     
    Apr 2, 2012 7:20 AM

    Offline
    Joined: May 2011
    Posts: 2422
    Bars on Activity timeline aren't showing.


     
    Pages (19) [1] 2 3 » ... Last »