MyAnimeList.net

Forums

Recent Posts | My Watched Topics | My Ignored Topics | Search

Cannot Edit Club Details => 500 Internal Server Error
MyAnimeList.net Forum »» Support »» Cannot Edit Club Details => 500 Internal Server Error

#1
02-23-13, 2:41 PM

Offline
Joined: Dec 2008
Posts: 3242
I get a 500 Internal Server Error when trying to edit this club's details section: http://myanimelist.net/clubs.php?cid=25397

It says: The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


It happened just now, & I've tried once everyday for the last 3 days. It doesn't matter what I edit & it does this even if I don't actually edit anything before I hit the button.

I assumed it happened because of the work being done on the site with the lag & statistics stuff. But... my stats are updating now, so I'm wondering if a different issue is causing it? Or maybe maintenance is still ongoing? I've tried searching the forums but can't find anything about this anywhere. And, I'm not having any problems elsewhere on the site. Can someone please look into it & let me know? Thanks.
Modified by Luna_, 04-19-13, 11:37 AM
 
#2
02-24-13, 12:40 PM
Forum Moderator
Online
Joined: Sep 2008
Posts: 10474
I looked at the BBCode of your club's details section and found the problem:

If you have a sequence of 2 or more "-" characters, you will get an internal server error. In your club description you're using this as a separator between sections:
---------------------------------

Removed these parts and you should be able to save the description without problems.

This only happens if the sequence of "-" characters is at the beginning of a line.

test -- test => no problems
test -- => no problems
-- test => internal server error
-- => internal server error

It's a bug and will hopefully be fixed soon, but until then you'll have to remove these lines or add something at the beginning of them in order to save any changes.
 
#3
02-25-13, 2:10 PM

Offline
Joined: Dec 2008
Posts: 3242
Thank you so much for taking the time to find a work around. That definitely was it. I've never ran into errors like that one so I was a baffled.
 
#4
02-28-13, 7:51 AM
News Team
Offline
Joined: Nov 2007
Posts: 18814
Could you look at this club as well? Same problem happened to me just now.

Luna_ said:
I looked at the BBCode of your club's details section and found the problem:

If you have a sequence of 2 or more "-" characters, you will get an internal server error. In your club description you're using this as a separator between sections:
---------------------------------

Removed these parts and you should be able to save the description without problems.

This only happens if the sequence of "-" characters is at the beginning of a line.

test -- test => no problems
test -- => no problems
-- test => internal server error
-- => internal server error

It's a bug and will hopefully be fixed soon, but until then you'll have to remove these lines or add something at the beginning of them in order to save any changes.


I did check the BBCode of in the club description before posting this and I don't think there's with that problem.

Thank you~
I Two Syaorans from Tsubasa RESERVoir CHRoNiCLE and TRC!!!

 
#5
02-28-13, 8:25 AM
Forum Moderator
Online
Joined: Sep 2008
Posts: 10474
@tsubasalover:

This club description also contains ----- sequences which cause the 500 internal server error. Either remove/replace these lines or put a different character at the beginning (a whitespace is enough) until the problem is fixed.
 
#6
02-28-13, 8:46 AM
News Team
Offline
Joined: Nov 2007
Posts: 18814
Ok, I will just delete everything with "----" because I cannot do anything with those from amazon and separation between recent and old news besides "----". Thank you very much.
I Two Syaorans from Tsubasa RESERVoir CHRoNiCLE and TRC!!!

 
#7
02-28-13, 12:55 PM

Offline
Joined: May 2007
Posts: 652
I strangely got this same 500 Internal Server Error when I tried to add a character just now. I was able to add two characters successfully out of three. I even tried like three times adding the same character and I keep getting the same error!
 
#8
03-01-13, 2:37 AM

Offline
Joined: May 2007
Posts: 652
I've encountered the error again. I'm not sure what's causing it. The directory for the image I'm uploading is the same for the two characters images I uploaded successfully after that. I tried to change the image name and even upload from a different directory.

tsubasalover said:
Ok, I will just delete everything with "----" because I cannot do anything with those from amazon and separation between recent and old news besides "----". Thank you very much.

You can always replace those text lines with an image. Just image google search "separator png", there are many varieties that may inspire you.
 
#9
03-01-13, 11:20 AM

Offline
Joined: May 2007
Posts: 652
I added the character without uploading a picture and it worked. Thanks for never responding I had to figure it out myself how to add to the DB. I still don't think this 500 Internal Error is related to uploading a picture. Someone may need to look into it maybe because I've never encountered it before and there's nothing wrong with the picture I was trying to upload. It's this one.
 
03-14-13, 9:14 PM

Offline
Joined: Apr 2009
Posts: 7546
As the creator of the Kitamura Eri Fanclub, I've been trying to update the club's details. Lately, all I'm getting is a 500 Internal Server Error when I click Save Changes. The club's admin SilentTruth is also getting this error when trying to do edits.

I tried editing club details in other clubs where I am an admin, and I can save changes without problems. I'm thinking this may be a club-specific bug.
 
03-14-13, 9:35 PM

Offline
Joined: Nov 2010
Posts: 17697
Maybe this thread can help you. Apparently you can't have these ----------- in your club info or else you get the error or something like that.
 
03-14-13, 10:11 PM

Offline
Joined: Apr 2009
Posts: 7546
I've found the problem, thanks a lot.

Seems to be a fairly recent bug.
 
03-20-13, 9:25 AM

Offline
Joined: May 2010
Posts: 1108
I was inactive for a very long time, and I just came back from hell yesterday. So I thought of reviving my club. I was able to edit the club information for a few times, but when I went back and wanted to edit it again, this keeps on showing up. :/ I'm kinda really pissed of right now because I can't friggin' edit my club. Is there any way to prevent it from happening? Or.. is it really gonna be like that for God knows how long. Please help, and also, now that I'm seeking for help, there is also one problem with my club -- the topic count. As you can see, there are no topics. So why is it like that? :/

Thank you very much in advance. :D
Modified by UsuiAyuzawa, 03-20-13, 6:05 PM
 
03-21-13, 4:02 AM
Forum Moderator
Online
Joined: Sep 2008
Posts: 10474
Threads merged.
Please see my post here and check if it's the same problem. If you don't have -- sequences in your club description but still get the internal server error, please send me a PM with your club description code.

UsuiAyuzawa said:
and also, now that I'm seeking for help, there is also one problem with my club -- the topic count. As you can see, there are no topics. So why is it like that? :/

This happens sometimes and might be lag related. At the moment there's no way how this can be fixed, sorry. Someone has to look into the problem.
 
03-21-13, 5:38 AM

Offline
Joined: May 2010
Posts: 1108
Thank you very much!
At first, I wasn't able to grab hold of the "-" sequence you were talking about (I am so stupid -.-') but I understood it after I checked my club description. Thank you very much for your help. :D
 
Top
Help     FAQ     About     Contact     Terms     Privacy     AdChoices